FrankForum (Frankness IS Forum)
http://brainout.net/frankforum/

Beating Apples lack of support infrastructure for older OS X releases....
http://brainout.net/frankforum/viewtopic.php?f=51&t=700
Page 1 of 1

Author:  5735guy [ 16 May 2017, 00:40 ]
Post subject:  Beating Apples lack of support infrastructure for older OS X releases....

....support for OS X Snow Leopard ended around 2013 although this was never made official by Apple.

There are workarounds for most software but up to date web browsers have dried up. For web browsing on Snow Leopard I use Firefox ESR 45.9 as the regular update channel is incompatible. So far I have encountered no issues with Firefox ESR 45.9 which also offers full HTML5 support.

There is one piece of software I cannot do without and that is iTunes for syncing my iPhone running iOS 10. The latest version of iTunes that will run on Snow Leopard by default is v11.4 which is no good whatsoever.

Time to take some drastic steps to get iTunes 12.6 and there was only one way to achieve it. I've taken the virtualisation route. Installed Parallels Desktop 9 (the latest version that will run on Snow Leopard) and installed the original version of Windows 8 in a virtual environment.

Sounds mad I know but there was good reason for selecting Windows 8. It runs much smoother in a virtual environment than Windows 7.

So now I have iTunes 12.6 running on OS X Snow Leopard and Windows 8 itself is almost invisible as I have it running in Parallels Desktop Coherence mode.

There is always a workaround. Apple may of abandoned the Snow Leopard user(which is still being sold in the Apple Store and unsupported) but the best of the cats lives on.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/